Resolved
The issue preventing some US users from accessing has been fully resolved. All systems are now operational. Thank you for your patience.
Investigating
Some users may be experiencing degraded performance within Harvey. Our team is working to identify the root cause, and we will provide updates as soon as we have more information.