Resolved
The issue affecting US processing times has been fully resolved. All systems are now operational. Thank you for your patience.
Monitoring
The issue affecting US Instance slowness has been resolved, and we are now monitoring the situation to ensure stability. We will provide further updates if necessary.
Identified
The issue affecting US instance load slowness has been identified. Our team is actively working on a solution to resolve the issue. We will continue to update you on progress.
Investigating
We are currently investigating reports of an issue affecting the loading speed in the US Instance. Our team is working to identify the root cause, and we will provide updates as soon as we have more information.